How to: install Diaspora on Mac OS X

October 7th, 2010

If you don’t happen to know already what Diaspora is, let me say this: Diaspora is the distributed, privacy aware, personally controlled, do-it-all, open source social network. I already have written a word or two about it in a Facebook post, but I’m not going to analyze here what Diaspora is, how it works, why you should like it and the such.

Straight to the point. How to install Diaspora on your Mac OS X machine. It’s pretty much simple if you are are familiar with console and unix commands. Let’s see how it goes.

Get the Source

git clone http://github.com/diaspora/diaspora.git

Install Dependencies via Homebrew

(if you don’t have HB, install this first + it requires XCode, so if you again don’t have XCode go and download XCode first)

ruby -e "$(curl -fsS http://gist.github.com/raw/323731/install_homebrew.rb)"

(If this complains you aren’t part of the staff group, run this first)

sudo dscl /Local/Default -append /Groups/staff GroupMembership $USER

Install MongoDB

brew install mongo

Run MongoDB manually

mongod run --config /usr/local/Cellar/mongodb/1.6.2-i386/mongod.conf

Plus, you can make it start on boot

cp /usr/local/Cellar/mongodb/1.6.2-i386/org.mongodb.mongod.plist ~/Library/LaunchAgents
launchctl load -w ~/Library/LaunchAgents/org.mongodb.mongod.plist

Install ImageMagick

brew install imagemagick

Make sure GEMS is up to date

sudo gem update --system

Get Bundler

sudo gem install bundler

Now build/run Diaspora!

cd diaspora_root
bundle install

Start Mongo (if you didn’t already)

mongod run --config /usr/local/Cellar/mongodb/1.6.2-i386/mongod.conf

Now run the app server (finally!)

cd diaspora_root
bundle exec thin start

Seed the DB with some info

rake db:seed:tom

Then point your browser to http://localhost:3000 and login in as tom/evankorth. Sounds good, huh?

Comments

  1. Hey I Found a Few “Problems”.
    After install MongoDb Dont Enter
    mongod run –config /usr/local/Cellar/mongodb/1.6.2-i386/mongod.conf
    Enter
    cd /usr/local/Cellar/mongodb/
    than enter “ls”
    than enter mongod run –config “/” and the resault of ls and “/mongod.conf
    You have to do this because Mongodb is bringing out every Few days updates and there are differences of 64bit and 32bit.
    Also diaspora is not everytime diasproa_root also find that out with ls

  2. I get some errors:

    $ cd diaspora_root
    -bash: cd: diaspora_root: No such file or directory

    $ bundle exec thin start
    Could not locate Gemfile

    I’m stuck, i dont konw what to do from here… can you help please?

Comments are closed.